2010 GMC Terrain - GMC Terrain Forum : GMC Terrain Forums
Reply
 
Share LinkBack Thread Tools
Old 07-20-2017, 09:24 PM   #1
Junior Member
 
Join Date: Jul 2017
Posts: 1
Default 2010 GMC Terrain

I had all 4 pistons replaced as well as both camshaft actuator solenoids. I now have the following error when tested:
"cam shaft position control"
Would this be the result of the work done above?
4ever30 is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2017, 08:05 AM   #2
DPK
Super Moderator
 
DPK's Avatar
 
Join Date: Sep 2015
Location: OKC, OK
Posts: 155
Default

I would say yes..either there is a calibration step required or a new cam-shaft position sensor is out of tolerance and needing replaced.
__________________
2015 Terrain/Denali
Summit White--V6-AWD
DPK is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:12 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.