2010 terrain.... passenger low beam not working ...has been replaced - GMC Terrain Forum : GMC Terrain Forums
Reply
 
Share LinkBack Thread Tools
Old 01-19-2017, 11:37 AM   #1
Junior Member
 
Join Date: Jan 2017
Posts: 1
Default 2010 terrain.... passenger low beam not working ...has been replaced

passenger low beam head light not working ... replaced and still nothing
.... help
great-grandfather is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Old 01-20-2017, 03:58 PM   #2
DPK
Super Moderator
 
DPK's Avatar
 
Join Date: Sep 2015
Location: OKC, OK
Posts: 155
Default

Hey Gramps,

Just double check that you installed the new Lamp correctly and solidly...Other than that..In the Fuse box(the one with the RED post for jumping sticking out of it)..There is a relay called the Hi-beam Relay #59..it also serves as the low beam relay..It could be faulty...they just un-plug.
__________________
2015 Terrain/Denali
Summit White--V6-AWD
DPK is offline  
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiTweet this Post!
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:17 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.